HDOJ 4771 Stealing Harry Potter's Precious(bfs + 状态压缩)

Stealing Harry Potter's Precious

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2619    Accepted Submission(s): 1195


Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 

Sample Input
  
  
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

Sample Output
  
  
-1 5
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5508  5507  5506  5505  5504
题解:关于此题, 我们可以首先把那k个位置变成1,2,3......k。然后搜索的时候每个节点带一个状态, 表示走了哪几个数, 一共有4个数, 如果用二进制表示, 我们每个节点开16个状态位标记就好了,然后每个节点自带一个状态,BFS即可。


#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;
const int N = 110;
int row, col;
int found;
char mp[N][N];
bool vis[N][N][16];

struct node{
	int x, y, t;
	int state;
};

bool is_point(int x, int y) {
	return x >= 0 && x < row && y >= 0 && y < col;
}

int search(int sx, int sy) {
	int dx[] = {0, 0, 1, -1};
	int dy[] = {1, -1, 0, 0};
	struct node cur = {sx, sy, 0, 0};
	if (mp[sx][sy] != '.')
		cur.state = 1 << (mp[sx][sy] - '0');
	vis[sx][sy][cur.state] = true;
	queue<node> q;
	q.push(cur);

	while (!q.empty()) {
		cur = q.front();
		q.pop();

		for (int i = 0; i < 4; ++i) {
			int tx = cur.x + dx[i];
			int ty = cur.y + dy[i];

			if (is_point(tx, ty) && mp[tx][ty] != '#' && vis[tx][ty][cur.state] == false) {
				struct node tmp = {tx, ty, cur.t + 1, cur.state};
				if (mp[tx][ty] != '.') 
					tmp.state |= 1 << (mp[tx][ty] - '0');
				vis[tx][ty][tmp.state] = true;
				if (tmp.state == found) return tmp.t;
				q.push(tmp);
			}
		}
	}

	return -1;
}

int main() {
	while (~scanf("%d%d", &row, &col), row && col) {
		int sx, sy;
		for (int i = 0; i < row; ++i) {
			scanf("%s", mp[i]);
			for (int j = 0; j < col; ++j) {
				if (mp[i][j] == '@') {
					mp[i][j] = '.';
					sx = i, sy = j;
				}
			}
		}
		int t, a, b;
		scanf("%d", &t);
		found = (1 << t) - 1;

		for (int i = 0; i < t; ++i) {
			scanf("%d%d", &a, &b);
			mp[a - 1][b - 1] = '0' + i;
		}

		memset(vis, false, sizeof(vis));
		int ans = search(sx, sy);
		printf("%d\n", ans);
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值