1045. Favorite Color Stripe (30) 简单动态规划(LCS的变形)

1045. Favorite Color Stripe (30)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

题意:给定一个数组a和一个数组b, 问能否在b中找到最长的子序列,使得其是a中的子序列,其中a中的子序列可以重复

题解:典型的动态规划题

其中dp[i][j] 表示 数组b的前i个元素和a中的前j个元素的可重复LCS的长度

状态转移方程为

dp[i][j] = dp[i - 1][j] + 1 (b[i] == a[j]);

dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]) (b[i] != a[j])


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int dp[10010][210];
int main() {
    int n, m, l;
    int a[10010], b[210];
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= m; ++i) scanf("%d", b + i);
    scanf("%d", &l);
    for (int i = 1; i <= l; ++i) scanf("%d", a + i);

    for (int i = 1; i <= l; ++i)
        for (int j = 1; j <= min(l, m); ++j) {
            if (a[i] == b[j]) dp[i][j] = dp[i - 1][j] + 1;
            else dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
        }

    printf("%d\n", dp[l][m]);

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值