Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16512 Accepted Submission(s): 11636
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
Author
Ignatius.L
Recommend
题解: 考虑n的m划分, 如果对于每个i来说, 都有ai > 0, 那么, {ai - 1} 就对应了n-m的m划分,另外, 如果存在ai=0, 那么这就对应了n的m-1划分.
综上: dp[i][j] = dp[i - j][j] + dp[i][j - 1];
#include <cstdio>
const int N = 121;
int dp[N][N];
void Init() {
dp[0][0] = 1;
for (int j = 1; j < N; ++j)
for (int i = 0; i < N; ++i) {
if (i >= j) dp[i][j] = dp[i - j][j] + dp[i][j - 1];
else dp[i][j] = dp[i][j - 1];
}
}
int main() {
Init();
int n;
while (~scanf("%d", &n))
printf("%d\n", dp[n][n]);
return 0;
}