POJ 1035 Spell checker (字符串模拟)



Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19085 Accepted: 6980

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
?deleting of one letter from the word; 
?replacing of one letter in the word with an arbitrary letter; 
?inserting of one arbitrary letter into the word. 
Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

题意:在一个已有的字典中找相似的单词,可以删,增,替换一个字符。


#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
char str1[10010][20],str2[100][20];
bool judge(char a[] , char b[])//判断两个单词是否可匹配成功
{
    int len1=strlen(a),len2=strlen(b);
    if(fabs(len1-len2)>1)//大于1不可能匹配成功
        return 0;
    else if(len1==len2)//相等就只能一个字符不同
    {
        int count=0;
        for(int i=0;i<len1;i++)
        {
            if(a[i]==b[i])
                count++;
        }
        if(count==len1-1)
            return 1;
        else
            return 0;
    }
    else if(len1>len2)
    {
        int count=0;
        for(int i=0,j=0;i<len1;i++)
        {
            if(a[i]!=b[j])
                continue;
            else
            {
                count++;
                j++;
            }
        }
        if(count==len1-1)
            return 1;
        else
            return 0;
    }
    else
    {
        int count=0;
        for(int i=0,j=0;i<len2;i++)
        {
            if(a[j]!=b[i])
                continue;
            else
            {
                count++;
                j++;
            }
        }
        if(count==len2-1)
            return 1;
        else
            return 0;
    }
}
int main()
{
    int p=0,q=0;
    while(scanf("%s",str1[p++]))
    {
        if(str1[p-1][0]=='#')
        {
            p--;
            break;
        }
    }
    while(scanf("%s",str2[q++]))
    {
        if(str2[q-1][0]=='#')
        {
            q--;
            break;
        }
    }
    for(int i=0;i<q;i++)
    {
        int flag=0;
        for(int j=0;j<p;j++)//第一遍遍历看是否有相同单词
        {
            if(strcmp(str2[i],str1[j])==0)
            {
                flag=1;
                printf("%s is correct",str2[i]);
                break;
            }
        }
        if(flag==0)
        {
            printf("%s:",str2[i]);
            for(int j=0;j<p;j++)//第二遍找相似的单词
            {
                if(judge(str2[i],str1[j])==1)
                printf(" %s",str1[j]);
            }
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值