POJ 1700 Crossing River(贪心)

Description
A group of N people wishes to go across a river with only one boat,
which can at most carry two persons. Therefore some sort of shuttle
arrangement must be arranged in order to row the boat back and forth
so that all people may cross. Each person has a different rowing
speed; the speed of a couple is determined by the speed of the slower
one. Your job is to determine a strategy that minimizes the time for
these people to get across.
Input

The first line of the input contains a single integer T (1 <= T <=
20), the number of test cases. Then T cases follow. The first line of
each case contains N, and the second line contains N integers giving
the time for each people to cross the river. Each case is preceded by
a blank line. There won’t be more than 1000 people and nobody takes
more than 100 seconds to cross.
Output

For each test case, print a line containing the total number of
seconds required for all the N people to cross the river.
Sample Input

1
4
1 2 5 10

Sample Output

17

样例解释:1和2过去,1回来送船。5和10过去,2回来送船,然后1和2一起过去。所用时间为2+1+10+2+2=17。

贪心思路:首先对他们从小到大排序。基于贪心思想
1.耗时最短的人在船上来回送人
2.耗时最短的人来回送船,然后让两个耗时最长的人一起走。(实现方法就是耗时最短的送船回来,俩新人人过去,耗时次短的来接最短的过岸)
这样就以4为一个循环。每次耗时最短+耗时次短+2新人,然后取min,当人数<=3时,情况唯一,直接特判输出。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int maxn=10005;
int a[maxn];
int main()
{
    int n,m;
    scanf("%d",&n);
    for(int k=0;k<n;k++)
    {
        int sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        scanf("%d",&a[i]);
        sort(a+1,a+m+1);
        for(int i=m;i>=1;i-=2)
        {
            if(i==3)
            {
                sum+=a[1]+a[2]+a[3];
                break;
            }
            if(i==2)
            {
                sum+=a[2];
                break;
            }
            if(i==1)
            {
                sum+=a[1];
                break;
            }
            else sum+=min(a[1]+2*a[2]+a[i],2*a[1]+a[i]+a[i-1]);
        }
        printf("%d\n",sum);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值