A1031 Hello World for U

44 篇文章 0 订阅

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h    d
e     l
l     r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible — that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 – 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h      !
e      d
l       l
lowor

把给定字符串按照U形进行输出。其中n1为左侧竖线包含的字符数,n2为底部横线包含的字符数,n3为右侧竖线包含的字符数,且n1,n2,n3均包含拐角处相交的字符。于是又n1+n2+n3 = N + 2恒成立。此外,对n1,n2,n3有限制:
(1)n1 = n3
(2)n2 >= n1
(3)前两个条件成立的前提下,n1尽可能大

idea

  • 限制条件为:
    在这里插入图片描述

n1 = n3 <=n2
其中,n1 + n2 + n3 = n + 2(n为所给字符串长度
加2是因为两个绿色的角角多算了一遍
==》则n1 = n2 = (n + 2) / 3 , n2 = n + 2 - 2 * n1

solution1

#include <stdio.h>
#include <string.h>
int main(){
	char c[100];
	int n, n1, n2, k = 0;
	scanf("%s", c);
	n = strlen(c);
	n1 = (n + 2) / 3;
	n2 = n - 2 * n1 + 2;//两个底角重复了一遍 
	char a[n1][n2];
	for(int i = 0; i < n1; i++)
		a[i][0] = c[k++];
	for(int i = 0; i < n1; i++)
		for(int j = 1; j < n2 - 1; j++)	{
			if(i != n1 - 1)
				a[i][j] = ' ';
			else 
				a[i][j] = c[k++];
		}
	for(int i = n1 - 1; i >= 0; i--)
		a[i][n2 - 1] = c[k++];
	for(int i = 0; i < n1; i++){
		for(int j = 0; j < n2; j++)
			printf("%c", a[i][j]);
		if(i != n1 - 1)
			printf("\n");
	}		
	return 0;
} 

solution(优化版

#include <stdio.h>
#include <string.h>
int main(){
	char s[81];
	scanf("%s", s);
	int n = strlen(s), n1 = (n + 2) / 3, n2 = n + 2 -  2 * n1,num = 0;
	char a[n1][n2];
	memset(a, ' ', sizeof(a));
	for(int i = 0; i < n1; i++)
		a[i][0] = s[num++];
	for(int i = 1; i < n2; i++)
		a[n1 - 1][i] = s[num++];
	for(int i = n1 - 2; i >= 0; i--)
		a[i][n2 - 1] = s[num++];
	for(int i = 0; i < n1; i++){
		for(int j = 0 ; j < n2; j++){
			printf("%c", a[i][j]);
		}
		printf("\n");
	}
	return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值