Best Reward (Manacher算法)

Best Reward


After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value.


Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000.

Output
Output a single Integer: the maximum value General Li can get from the necklace.
Sample Input
2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac
Sample Output
1
6

题目大意:

字母表的26个字母都有一个价值,给你一个字符串,将该字符串切成两份,对于每一份,如果是回文串,就获得该子串的字母价值

之和,否则该子串的价值为0。求出将字符串切成两份后能够获得的最大价值。

算法思想:先用Manacher算法求出以每个字母为中心的回文串的长度,并计算该字符串的前缀价值和。然后枚举切割点,得到两份

子串。这样就可以知道每个子串的中心点,然后检查以该子串的中心点作为中心点的回文串的长度,如果长度等于该子串的长度,

那么就加上该子串的价值。然后和最优价值比较就行了。

写代码的时候一定要搞清楚for循环是的上下界否则会出bug很难找

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
using namespace std;
const int MAXN = 500100;
char s[MAXN];//原字符串
char New[MAXN<<1];//更改后的字符串
int len[MAXN<<1];//len数组
int pre[MAXN],post[MAXN];//pre[i]表示s字符串前i字符是回文,post[i]表示后i个字符是回文
int val[30];
int sum[MAXN];//表示字符串s的每个字符价值前缀和
int getNew(int n){
    int i;
    int cnt = 0;
    New[cnt++] = '@';
    New[cnt++] = '#';
    for(i = 0; i < n; i++){
        New[cnt++] = s[i];
        New[cnt++] = '#';
    }
    New[cnt] = '\0';
    return cnt;
}

void Manacher(int n){
    int i;
    int mx = 0,po = 0;
    for(i = 1; i < n; i++){
        if(mx > i){
            len[i] = min(mx-i,len[2*po-i]);
        }
        else{
            len[i] = 1;
        }
        while(New[i-len[i]] == New[i+len[i]]/* && i-len[i] >= 0 && i+len[i] < n*/){
            len[i]++;
        }
        if(i+len[i] > mx){
            mx = i+len[i];
            po = i;
        }
        if(i-len[i] == 0){
            pre[len[i]-1] = 1;
        }
        if(i+len[i] == n){
            post[len[i]-1] = 1;
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(len,0,sizeof(len));
        memset(pre,0,sizeof(pre));
        memset(post,0,sizeof(post));
        memset(val,0,sizeof(val));
        int i;
        for(i = 0; i < 26; i++){
            scanf("%d",&val[i]);
        }
        scanf("%s",s);
        int n = strlen(s);
        sum[0] = 0;
        for(i = 1; i <= n; i++){//注意这里求前缀和,i从1到n,但字符串应该是i-1,改了一下午才找出这个bug
            sum[i] = val[s[i-1]-'a'] + sum[i-1];
        }
        n = getNew(n);
        Manacher(n);
        n = strlen(s);
        int ans = -INF;
        for(i = 1; i < n; i++){
            int tmp = 0;
            if(pre[i]){
                tmp += sum[i];//这里注意sum是从1开始记录的
            }
            if(post[n-i]){
                tmp += (sum[n]-sum[i]);
            }
            if(tmp > ans)
                ans = tmp;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值