HDU 2973 YAPTCHA(威尔逊定理)

YAPTCHA

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 930    Accepted Submission(s): 491


Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output
For each n given in the input output the value of Sn.
 

Sample Input
  
  
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output
  
  
0 1 1 2 2 2 2 3 3 4 28 207 1609
 

Source
 

题意:
给了你一个公式,让你求这个公式。

POINT:
利用威尔逊定理:
p 质数,则 p 可整除 (p-1)!+1
若3k+7为质数,就是1,其他情况则是0。
实求x属于(1,n)时3*x+7中有几个质数。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
//int a[1000000];
int num=0;
int f[3000000+10];
int ans[1000000];
void init()
{
    memset(f,1,sizeof f);
   // a[++num]=2;
    for(int i=4;i<=3000007;i+=2) f[i]=0;
    for(int i=3;i<=3000007;i++)
    {
        if(f[i])
        {
           // a[++num]=i;
            for(int j=i*3;j<=3000007;j=j+i*2)
            {
                f[j]=0;
            }
        }
    }
    ans[0]=0;
    for(int i=1;i<=1e6;i++)
    {
        if(f[i*3+7])
        {
            ans[i]=ans[i-1]+1;
        }
        else
            ans[i]=ans[i-1];
    }
  //  printf("%d",num);
}
int main()
{
    init();
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",ans[n]);
    }
    
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值