练习二1001

Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 75   Accepted Submission(s) : 25
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2<br>100<br>-4<br>
 

Sample Output
  
  
1.6152<br>No solution!<br>

题意:输入一个数Y,在0到100之间,找到使8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y成立的x,且误差小于1e-6。



思路:利用二分法进行搜索,将当前的最小值和最大值带入上式并作差,如果差小于1e-6,则所求的x为(最大值+最小值)/2,否则判断(最大值+最小值)/2与Y的大小,若比Y大,将(最大值+最小值)/2作为最大值,再循环上述步骤。若比Y小,将(最大值+最小值)/2,作为最小值,循环进行上述步骤。

#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
double A(double x)
{
    return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*pow(x,1)+6);
}
int main()
{
    double  y;
    int T;
        cin>>T;
    while(T--)
    {
        cin>>y;
        if(A(0)>y||A(100)<y)
        {
            cout<<"No solution!"<<endl;
            continue;
        }
        else{
                double high,low,mid;
        high=100;
        low=0;
            while(low+1e-8<high)
            {
                mid=(high+low)/2;
                if(A(mid)>y)
                    high=mid;
                else
                    low=mid;
            }
          printf("%.4lf\n",low);
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值