二分 hdu2911 Can you solve this equation? 详细解答

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13416    Accepted Submission(s): 5988


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 

Author
Redow
 
题目大意:给了一个方程式,给出一个y要求x在0~100之前是否存在对应值;并输出结果。
题目分析:不难看出此题应用二分求解。
代码:
#include <iostream>
#include <cmath>
using namespace std;
double y;
double f(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}
double M(double x1,double x2)
{
    double x3,y1,y2,y3;
    y1 = y-f(x1);
    y2 = f(x2)-y;
    if(y1<0||y2<0)
        return 0;
    while (fabs(y1 - y2) >= 0.0001)//判断y对应值 用x会错(说明在代码后)
            {
                x3 = (x1 + x2) / 2;
                y3 = f(x3) - y;//先计算在进行比较有利于节约时间 
                if (y3 >= 0)
                    x2 = x3;
                else
                    x1 = x3;
                y1 = f(x1) - y;
                y2 = f(x2) - y;
            }
    return x3;
}
int main()
{
    int t,i;
    double x1,x2;
    while(scanf("%d",&t)!=EOF)
    {
        for(i=0; i<t; i++)
        {
            scanf("%lf",&y);
            x1 = 0;
            x2 = 100;
            if(f(x1)==y)
            printf("%.4lf\n",x1);
            else if(f(x2)==y)
            printf("%.4lf\n",x2);
            else if(!M(x1,x2))
            printf("No solution!\n");
            else
            printf("%.4lf\n",M(x1,x2));
        }
    }
    return 0;
} 

注意判断精度时要看y的值,因为题目要求就是看y值是否符合,刚开始用x就是不对,后来想明白是这么回事。其他地方没什么可说的了吧!!! 微笑
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值