HDU 2199

点击打开链接

 Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20197 Accepted Submission(s): 8892


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
  
  
2 100 -4

Sample Output
  
  
1.6152 No solution!
题意:利用二分搜索求方程的解,只需输出一个实数(精确到小数点后4位),这是方程的解,或者“没有解”!如果x在0和100之间,方程没有解的话。
注:原型:extern float pow(float x, float y);
  
    用法:#include <math.h>
  
    功能:计算x的y次幂。
  
    说明:x应大于零,返回幂指数的结果。
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const double esp=1e-10;//十的负十次方
double f(double x)
{
    return 8.0*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double y;
        scanf("%lf",&y);
        double left=0.0;
        double right=100.0;
        if(f(left)>y||f(right)<y)
        {
            printf("No solution!\n");
            continue;
        }
        while(right-left>esp)
        {
            double mid=(left+right)/2;
            if(f(mid)>y)
            {
                right=mid;
            }
            else
            {
                left=mid;
            }

        }
        printf("%.4lf\n",right);

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值