【PAT甲级 - C++题解】1039 Course List for Student

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1039 Course List for Student (pintia.cn)
🔑中文翻译:学生课程列表
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1039 Course List for Student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N**i (≤200) are given in a line. Then in the next line, N**i student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
题意

第一行包含两个整数 N N N K K K ,分别表示需要查询的学生数量以及课程数量。

接下来包含 K K K 个课程的具体报名信息。

每个课程信息的第一行包含两个整数 i i i N i N_i Ni ,分别表示该课程的编号(所有课程编号从 1 1 1 K K K)以及报课人数。

第二行包含 N i N_i Ni 个学生姓名,学生姓名由三个大写字母和一个数字组成。

最后一行包含 N N N 个学生姓名,表示要查询的学生名单。

输出共 N N N 行,每行输出一个学生的姓名,报课总数,以及所有报名的课程的编号(按照升序排列)。

学生信息的输出顺序应与查询名单中的顺序一致。

思路
  1. 用一个哈希表存储每个学生要选的课程是什么,key 是学生姓名,value 是该学生所选课程的编号,用 set 来存储,它可以自动从小到大进行排序,这样到时候输出的时候就不用再去排序了。
  2. 边输入学生的信息边输出该学生的信息,因为刚才每个课程选课学生的信息已经保存起来了,所以现在就按照给定学生的名单去输出对应学生的选课信息。注意输出的时候要先输出姓名,然后输出选课数量,最后再依次按照从小到大输出课程编号。
代码
#include<bits/stdc++.h>
using namespace std;

unordered_map<string, set<int>> res;

int main()
{
    int n, m;
    cin >> n >> m;
    //输入学生信息
    for (int i = 1; i <= m; i++)
    {
        int index, k;
        cin >> index >> k;
        for (int i = 0; i < k; i++)
        {
            string name;
            cin >> name;
            res[name].insert(index);
        }
    }
	
    //输出每个学生的选课信息
    for (int i = 0; i < n; i++)
    {
        string name;
        cin >> name;
        cout << name;
        if (res.count(name))	//判断该学生是否有选课
        {
            cout << " " << res[name].size();
            for (auto& s : res[name])
                cout << " " << s;
            cout << endl;
        }
        else puts(" 0");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值