POJ - 3259 Wormholes(多种方法求负权回路)+译文

50 篇文章 4 订阅
41 篇文章 2 订阅

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
t译文:农夫约翰在探索他的许多农场,发现了一些惊人的虫洞。虫洞是很奇特的,因为它是一个单向通道,可让你进入虫洞的前达到目的地!他的N(1≤N≤500)个农场被编号为1..N,之间有M(1≤M≤2500)条路径,W(1≤W≤200)个虫洞。作为一个狂热的时间旅行FJ的爱好者,他要做到以下几点:开始在一个区域,通过一些路径和虫洞旅行,他要回到最开时出发的那个区域出发前的时间。也许他就能遇到自己了:)。为了帮助FJ找出这是否是可以或不可以,他会为你提供F个农场的完整的映射到(1≤F≤5)。所有的路径所花时间都不大于10000秒,所有的虫洞都不大于万秒的时间回溯。

 
输入
第1行:一个整数F表示接下来会有F个农场说明。
每个农场第一行:分别是三个空格隔开的整数:N,M和W
第2行到M+1行:三个空格分开的数字(S,E,T)描述,分别为:需要T秒走过S和E之间的双向路径。两个区域可能由一个以上的路径来连接。
第M +2到M+ W+1行:三个空格分开的数字(S,E,T)描述虫洞,描述单向路径,S到E且回溯T秒。
输出
F行,每行代表一个农场
每个农场单独的一行,” YES”表示能满足要求,”NO”表示不能满足要求。
NO
YES

哈哈,要想回到原点。。。虫洞可以让 你回到过去,就相当于一个负权。。。然后判断是否存在负环,即走走走。。。然后又走回去了,,,

方法一:Bellmand---Ford
 

#include<stdio.h>
#define INF 0x3f3f3f3f
int dis[10000],bak[10000],u[10000],v[10000],t[10000],check,flag,n,m,w;
int main()
{
    int f;
    scanf("%d",&f);
    while(f--)
    {
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&u[i],&v[i],&t[i]);
        for(int i=m+1;i<=m+w;i++)
        {
            scanf("%d%d%d",&u[i],&v[i],&t[i]);   //虫洞时间是负的·且单向
            t[i]=-t[i];
        }
        for(int i=1;i<=n;i++)
            dis[i]=INF;
        dis[1]=0;
        for(int k=1;k<n;k++)
        {
            for(int i=1;i<=n;i++)bak[i]=dis[i];  //将dis数组备份,可省时,提前跳出循环
            for(int i=1;i<=m;i++)
            {   
                if(dis[v[i]]>dis[u[i]]+t[i])    //农场两个方向都要判断
                    dis[v[i]]=dis[u[i]]+t[i];
                if(dis[u[i]]>dis[v[i]]+t[i])
                    dis[u[i]]=dis[v[i]]+t[i];
            }
            for(int i=m+1;i<=m+w;i++)
            {
                if(dis[v[i]]>dis[u[i]]+t[i])    //注意!!!!!!!!!!!!!从v[i]-u[i]是正的,方向别弄错了。。
                    dis[v[i]]=dis[u[i]]+t[i];
            }
            check=0;
            for(int i=1;i<=n;i++)
                if(bak[i]!=dis[i])
            {
                check=1;
                break;
            }
            if(check==0)break;
        }
        flag=0;
        for(int i=1;i<=m;i++)               //虫洞不用判断,因为本身就是负的,判断m就好了.加上也行。
            if(dis[v[i]]>dis[u[i]]+t[i])flag=1;
        if(flag)
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

方法二(floyd):

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int map[505][505],n,m,k,num=0;
int floyd()
{
    int i,j,k,f=0;
    for(k=1;k<=n;k++)
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++)
            {
                int t=map[i][k]+map[k][j];
                if(map[i][j]>t)map[i][j]=t;
                /*map[i][j]=min(map[i][j],map[i][k]+map[k][j]);*/   //注意这里,用错了会超时!!!!不用min就跑了1688ms,,,,
            }
            if(map[i][i]<0)return 1;
    }
    return f;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int i,j,a,b,c;
        scanf("%d%d%d",&n,&m,&k);
        memset(map,0x3f3f3f3f,sizeof(map));
        for(i=1;i<=n;i++)map[i][i]=0;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c<map[a][b])map[a][b]=map[b][a]=c;
        }
        for(i=1;i<=k;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=-c;
        }
        num++;
        int f=floyd();
        if(!f)printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

转载自:https://blog.csdn.net/zitian246/article/details/76082393

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值