HDU6168(暴力模拟)

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 750    Accepted Submission(s): 393

Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

Source

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include <math.h>
using namespace std;
int vis[125300];
int s[125300];
int a[125300];
int b[125300];
int m;
int main()
{
	int cnt;
    while(scanf("%d",&m)!=EOF)
    {
        for(int i=1;i<=m;i++)
        scanf("%d",&s[i]);
        sort(s+1,s+m+1); 
        memset(vis,0,sizeof(vis)); 
        a[1]=s[1];
        a[2]=s[2];
        
        for(int j=3;j<=m;j++)
        {
            int mid=a[1]+a[2];
            if(s[j]==mid)
            {
                vis[j]=1;
                break;
            }
        }
        int i=3;
		cnt=2;
        while(i <= m)
        {
            if(!vis[i])
            {
                a[++cnt]=s[i];
                //cout<<a[cnt]<<endl;
                for(int k=1,j=i+1;k<cnt&&j<=m;j++)
                {
                        int mid=a[k]+s[i];
                        if(s[j]==mid&&vis[j]==0)
                        {
                        	k++;
                            //cout<<j<<endl;
                            vis[j]=1;
                        }
                }
            }   
            i++;
		}
        printf("%d\n",cnt);
        for(int i=1;i<=cnt;i++)
        { 
			printf("%d",a[i]);
        	if(i!=cnt)
        	printf(" ");
			
	    }
        cout<<endl;
       }
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值