HDU 6168 Numbers(规律)

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 615    Accepted Submission(s): 323


Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

题意:一个数列 a ,将其任意两项相加得到数列 b ,给出数列 a,b 混合后的数列,问原数列的组合?

解题思路:给定序列中的最小的两个数一定在a序列中,两者相加的和一定在b序列中,把所确定的数从给定序列中拿去,则剩下的数中最小的一定在a序列中,其与所确定的a序列的元素相加一定在b序列中,通过这个方法一直往下推就可以找出a序列中的组合
a的de aai 10 9 ]

源代码:
#include<bits/stdc++.h>
using namespace std;
int a[125255];
int num[125255];
map<int ,int>s;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int k=1;
        s.clear();//清空s
        for(int i=1;i<=n;i++)
        {

            scanf("%d",&num[i]);
            s[num[i]]++;
        }
        a[k++]=num[1];a[k++]=num[2];
        s[num[1]+num[2]]--;//删去原序列中b的元素
        //s[num[1]]--;s[num[2]]--;//删去原序列中a的元素
        for(int i=3;i<=n;i++)
        {
            if(s[num[i]]>0)
            {

                s[num[i]]--;//删去原序列中a的元素
                a[k++]=num[i];
                for(int j=1;j<k-1;j++)
                {
                    s[a[j]+a[k-1]]--;//删去原序列中b的元素
                }
            }
        }
        printf("%d\n",k-1);
        for(int i=1;i<k;i++)
            printf("%d%c",a[i],i==k-1?'\n':' ');
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值