HDU 3853 LOOPS (概率DP)

HDU 3853 LOOPS (概率DP)http://acm.hdu.edu.cn/showproblem.php?pid=3853

题面:

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 4567    Accepted Submission(s): 1828


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
  
  
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
  
  
6.000

题目大意:

再一个R*C的网格中从左上角(1,1)走到右下角(r,c),每走一格需要消耗2个单位的能量,且每次走动,都可以选择不动,向下走和向右走三种方向。且已知三种不同走动的概率,求需要能量的期望。


题目分析:

对于每次走动,dp[i][j]记录从i,j出发到终点所需的期望,dmap[i][j][k]记录每次走动三种选择的概率,按照数学期望公式去做即可。


代码实现:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>

using namespace std;

double dmap[1010][1010][5];
double dp[1010][1010];
int main()
{
    int r,c;
    while(scanf("%d%d",&r,&c)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=r;i++)
        {
            for(int j=1;j<=c;j++)
            {
                for(int k=0;k<3;k++)
                {
                    scanf("%lf",&dmap[i][j][k]);
                }
            }
        }
        for(int i=r;i>0;i--)
        {
            for(int j=c;j>0;j--)
            {
                if(i==r && j==c) ///到达终点了
                    continue;
                if(fabs(1-dmap[i][j][0])<1e-7) ///留在原地的概率为1
                {
                    continue;
                }
                dp[i][j]=(dp[i][j+1]*dmap[i][j][1]+dp[i+1][j]*dmap[i][j][2]+2)/(1-dmap[i][j][0]);
            }  ///到达下一格
        }
        printf("%.3lf\n",dp[1][1]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值