POJ2387 Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.


Status Accepted
Time 188ms
Memory 8120kB
Length 1103
Lang C++
Submitted
题目大意:

输入 
1行:两个整数:T和N 
行2..T + 1:每行将跟踪描述为三个空格分隔的整数。
前两个整数是轨迹行进的地标。第三个整数是路径的长度,范围为1..100。 
输出 
Line 1:一个整数,Bessie必须旅行的最小距离,从地标N到地标1。

输出从1到N的最短路径,每一个路径都有一个距离花费,T行坐标,存在多条路径到达一个目的地,所有建立无向图时要判断,存两点间最短的路径。

#include<iostream>
using namespace std;
#define INF 1<<30 
#define MAXN 2007
int dist[MAXN],prev[MAXN],c[MAXN][MAXN];
void dijkstra(int n,int v)
{
	bool s[MAXN];
	int i,j;
	for(i=1;i<=n;i++)
	{
		dist[i]=c[v][i];
		s[i]=false;
		/*if(dist[i]==INF)	prev[i]=0; 
		else	prev[i]=v;	//用来存路径 */
	}
	dist[v]=0;s[v]=true;
	for(i=1;i<=n;i++)
	{
		int temp=INF;
		int u;
		for(j=1;j<=n;j++)
		{
			if((!s[j])&&(dist[j]<temp))
			{
				u=j;
				temp=dist[j];
			}
		}
		s[u]=true;
		for(j=1;j<=n;j++)
		{
			if((!s[j])&&(dist[u]+c[u][j]<dist[j]))
			{
				//cout<<u<<" "<<j<<" "<<dist[u]+c[u][j]<<" "<<dist[j]<<endl;
				dist[j]=dist[u]+c[u][j];
				//prev[j]=u;
			}
		}
	}
}
int main()
{
	int t,fn;
	int x,y,z;
	while(scanf("%d%d",&t,&fn)!=EOF)
	{
		for(int i=1;i<=fn;i++)
			for(int j=1;j<=fn;j++)
			{
				if(i==j)
					c[i][j]=0;
				else
					c[i][j]=c[j][i]=INF;
			 } 
				
		for(int i=1;i<=t;i++)
		{
			cin>>x>>y>>z;
			if(c[x][y]>z)
				c[x][y]=c[y][x]=z;
		}
		dijkstra(fn,1);
		cout<<dist[fn]<<endl;
		/*cout<<"路径:"<<endl;
		for(int j=1;j<=fn;j++)
			cout<<j<<"->"<<prev[j]<<" ";*/
	} 
	return 0;
}

















































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值