2010年西北工业大学机试第八题

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

 

#include<stdio.h>
#include<string.h>
using namespace std;
//A-K用0-10代表,0表示不通,1表示通 
int out[11][4]={{1,0,1,0},{1,0,0,1},{0,1,1,0},{0,1,0,1},{1,1,0,0},{0,0,1,1},{1,0,1,1},{1,1,1,0},{0,1,1,1},{1,1,0,1},{1,1,1,1}};
int cnt = 0,m,n,map[105][105],book[105][105]={0};
//上下左右四个方向 
int next[4][2]={ {-1,0},{1,0},{0,-1},{0,1} };
int judge(int x,int y,int i){
	//越界 
	if(x < 0||x >= n||y < 0||y >= m){
		return 0;
	}
	int index = 0;
	switch(i){
		case 0://下边可以通过管道上来,判断上面是否可以通过管道下去 
			index = out[ map[x][y] ][1];
			break;
		case 1://上边可以通过管道下来,判断下面是否可以通过管道上去 
			index = out[ map[x][y] ][0];
			break;
		case 2://右边可以通过管道到左边,判断左边是否可以通过管道到右边 
			index = out[ map[x][y] ][3];
			break;
		case 3://左边可以通过管道到右边,判断右边是否可以通过管道到左边 
			index = out[ map[x][y] ][2];
			break;
	}
	return index;//返回状态,0表示不通,1表示通 
}
void dfs(int x,int y){
	for(int i = 0;i < 4;i++){
		int x1 = x+next[i][0];
		int y1 = y+next[i][1];
		//该管道可以通向另外一个方向,另外一个方向可以通过该管道,并且另外一个管道没有遍历过 
		if(out[ map[x][y] ][i]&&judge(x1,y1,i)&&book[ x1 ][ y1 ] == 0){
			book[ x1 ][ y1 ] = 1;//标记 
			dfs(x1,y1);
		}
	}
}
int main(){

	char s[105];
	scanf("%d%d",&n,&m);
	while(n != -1&& m != -1){
		memset(map,0,sizeof(map));//归零 
		memset(book,0,sizeof(book));//归零 
		cnt = 0;//归零 
		for(int i = 0;i < n;i++){
			scanf("%s",s);
			for(int j = 0;j < m;j++){
				map[i][j] = s[j] - 'A';
			}
		}
		for(int i = 0;i < n;i++){
			for(int j = 0;j < m;j++){
				if(book[i][j] == 0){
					book[i][j] = 1;
				//	printf("%d %d\n",i,j);
					cnt++;
					dfs(i,j);
				}
			} 
		}
		printf("%d\n",cnt);
		scanf("%d%d",&n,&m);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值