HDU 5831 Rikka with Parenthesis II 【贪心】

10 篇文章 0 订阅

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1612    Accepted Submission(s): 709


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence  S , and he wants Rikka to choose two different position  i,j  and swap  Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
  
  
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.
 

Author
学军中学
 

Source
 

题解:左括号和右括号个数不相等是No,n=2的时候如果是()也是no,因为必须交换一次,就会变成)(,所以是No。否则如果出现一个没有与其相匹配的右括号,就是右括号出现在与他匹配的左括号之前,如果这种情况出现了三次或三次以上就是No,其余是Yes。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e6+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int i,j,k,n,m;
int sg[M];
int vis[M];
int gcd,x,y;
ll p,q;
ll ans;
ll sum[M];
int a[M];
char s[M];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        scanf("%s",s);
        ms(a,0);
        int sum=0;
        int sum1=0;
        int sum2=0;
        int ans=0;
        int len=strlen(s);
        for(int i=0;i<n;i++){
            if(s[i]=='('){
                a[i]=1,sum1++;
                sum++;
            }
            else {
                a[i]=-1,sum2++;
                if(sum>0)sum--;
                else ans++;
            }
        }
        if(sum1!=sum2)printf("No\n");
        else {
            if(ans>=3)printf("No\n");
            else if(len==2&&ans==0)printf("No\n");
            else printf("Yes\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值