hdu 5831 Rikka with Parenthesis II(2016 Multi-University Training Contest 8——模拟)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5831

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 403    Accepted Submission(s): 250


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence  S , and he wants Rikka to choose two different position  i,j  and swap  Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
  
  
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.
 

Author
学军中学
 

Source
 
题目大意:给一个长度为n的字符创,字符串中只包含'('')',要求每次必须交换其中两个位置,有且仅有一次,问交换之后括号能都匹配。

解题思路:情况比较多,把每一种情况分析清楚即可。
1、n是奇数,输出No。
2、n=2的时候,只有‘)’和‘(’交换之后才能匹配,这种情况输出Yes,否则No。
3、左括号和右括号个数不等,输出No。
4、匹配问题:如果出现一个没有与其相匹配的右括号。就是右括号出现在与其匹配的左括号之前,这种情况不能超过两次,因为每次只能交换一次,但是因为两个不匹配的有这种情况))((这种情况只要交换1,4就可以了,所以也是一次。综上,如果不匹配情况出现了三次或三次以上就输出No,否则输出Yes。

详见代码。
#include <iostream>
#include <cstdio>

using namespace std;

const int N=1e5+50;
char ch[N];

int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,k=0,s1=0,s2=0,s=0;
        scanf("%d",&n);
        scanf("%s",ch);
        if (n%2==1)
        {
            printf ("No\n");
            continue;
        }
        if (n==2)
        {
            if (ch[0]==')'&&ch[1]=='(')
            {
                printf ("Yes\n");
                continue;
            }
            else
            {
                printf ("No\n");
                continue;
            }
        }
        for (int i=0;i<n;i++)
        {
            if (ch[i]=='(')
            {
                s1++;
            }
            else
                s2++;
        }
        if (s1!=s2)
        {
            printf ("No\n");
            continue;
        }
        for (int i=0;i<n;i++)
        {
            if (ch[i]=='(')
                s++;
            else
            {
                if (s>0)
                    s--;
                else if (s<=0)
                    k++;
            }
            if (k==3)
                break;
        }
        if (k==3)
            printf ("No\n");
        else
            printf ("Yes\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值