5103: Electric Fence :皮克定理的运用

描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20
 

题解:

这里可以运用皮克定理:一个关于格点图内点与边界点及其面积的表达式

S=P+A/2-1

S是图形面积

P是内点

A是外点

#include<iostream> 
#include<algorithm> 
#include<queue>
#include<stack>
#include<cmath>
#include<vector>
#include<iomanip>
#include<string.h>
#include<set>
#include<string>
#include<map>
#include<bitset>
#pragma warning(disable : 4996)
using namespace std;
int gcd(int x, int y)
{
    if (y == 0)
    {
        return x;
    }
    return gcd(y, x % y);
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    //数据输入
    int n, m, p;
    cin >> n >> m >> p;
    double s = p * m / 2;
    //用辗转相除法求最大公约数来得到边界点的数量
    int k1 = gcd(n, m), k2 = gcd(abs(n - p), m), k3 = p;
    cout << (int)(s - (k1 + k2 + k3) / 2 + 1)<<endl;
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值