TZOJ 5103 Electric Fence (皮克定理)

描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20

题意

在题目给出的三个点(0,0),(m,n)和(p,0)所围成的三角形内有几个点?

分析

运用皮克定理

皮克定理是指一个计算点阵中顶点在格点上的多边形 面积公式 ,该公式可以表示为S=a+b÷2-1,其中a表示 多边形 内部的点数,b表示多边形落在 格点 边界上的点数,S表示 多边形 的面积。

根据皮克定理的公式得出ans=S-b/2+1。

格点数 = gcd(abs(x2-x1),abs(y2-y1))

代码

#include<bits/stdc++.h>
#define pi acos(-1.0)
using namespace std;
typedef long long ll;
int gcd(int x,int y)
{
	if(y==0)
	return x;
	return gcd(y,x%y);
}
int main()
{
	int n,m,p;
	scanf("%d%d%d",&n,&m,&p);
	int ans=p*m/2-(gcd(n,m)+gcd(abs(n-p),m)+p)/2+1;
	printf("%d\n",ans);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值