LCIS
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5782 Accepted Submission(s): 2512
Problem Description
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
Input
T in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
Output
For each Q, output the answer.
Sample Input
1 10 10 7 7 3 3 5 9 9 8 1 8 Q 6 6 U 3 4 Q 0 1 Q 0 5 Q 4 7 Q 3 5 Q 0 2 Q 4 6 U 6 10 Q 0 9
Sample Output
1 1 4 2 3 1 2 5
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
const int maxn=100010;
int num[maxn];
int msum[maxn<<2];
int lsum[maxn<<2];
int rsum[maxn<<2];
void pushup(int l,int r,int rt){
lsum[rt]=lsum[rt<<1];
rsum[rt]=rsum[rt<<1|1];
msum[rt]=max(msum[rt<<1],msum[rt<<1|1]);
int mid=(l+r)>>1;
int len=r-l+1;
if(num[mid]<num[mid+1]){
if(lsum[rt]==len-len/2)
lsum[rt]+=lsum[rt<<1|1];
if(rsum[rt]==len/2)
rsum[rt]+=rsum[rt<<1];
msum[rt]=max(msum[rt],lsum[rt<<1|1]+rsum[rt<<1]);
}
}
void build(int l,int r,int rt){
if(l==r){
msum[rt]=lsum[rt]=rsum[rt]=1;
return ;
}
int mid=(l+r)>>1;
build(lson);
build(rson);
pushup(l,r,rt);
}
void update(int p,int l,int r,int rt){
if(l==r)return ;
int mid=(l+r)>>1;
if(p<=mid)update(p,lson);
else update(p,rson);
pushup(l,r,rt);
}
int query(int left,int right,int l,int r,int rt){
if(left<=l&&r<=right){
return msum[rt];
}
int mid=(l+r)>>1;
int lans=0,rans=0,ans=0;
if(left<=mid)lans=query(left,right,lson);
if(right>mid)rans=query(left,right,rson);
ans=max(lans,rans);
if(num[mid]<num[mid+1]){
ans=max(ans,min(mid-left+1,rsum[rt<<1])+min(right-mid,lsum[rt<<1|1]));
}
return ans;
}
int main()
{
int t,i,j,k,n,m;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
for(i=1;i<=n;++i){
scanf("%d",&num[i]);
}
build(1,n,1);
int a,b;
char s[2];
while(m--){
scanf("%s%d%d",s,&a,&b);
if(s[0]=='U'){
a++;
num[a]=b;
update(a,1,n,1);
}
else {
a++;b++;
printf("%d\n",query(a,b,1,n,1));
}
}
}
return 0;
}