hdoj4716A Computer Graphics Problem

A - A Computer Graphics Problem
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard. 
We have designed a new mobile phone, your task is to write a interface to display battery powers. 
Here we use '.' as empty grids. 
When the battery is empty, the interface will look like this: 
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this: 
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters. 
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

Input

The first line has a number T (T < 10) , indicating the number of test cases. 
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

Output

For test case X, output "Case #X:" at the first line. Then output the corresponding interface. 
See sample output for more details.
 

Sample Input

       
       
2 0 60
 

Sample Output

       
       
Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int main()
{
	int n,t,i,j,k=1;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		printf("Case #%d:\n",k++);
		printf("*------------*\n");
		for(i=0;i<10-n/10;++i){
			printf("|............|\n");
		}
		for(j=i;j<10;++j){
			printf("|------------|\n");
		}
		printf("*------------*\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值