GT and numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1606 Accepted Submission(s): 401
Problem Description
You are given two numbers
N
and
M
.
Every step you can get a new N in the way that multiply N by a factor of N .
Work out how many steps can N be equal to M at least.
If N can't be to M forever,print −1 .
Every step you can get a new N in the way that multiply N by a factor of N .
Work out how many steps can N be equal to M at least.
If N can't be to M forever,print −1 .
Input
In the first line there is a number
T
.
T
is the test number.
In the next T lines there are two numbers N and M .
T≤1000 , 1≤N≤1000000 , 1≤M≤263 .
Be careful to the range of M.
You'd better print the enter in the last line when you hack others.
You'd better not print space in the last of each line when you hack others.
In the next T lines there are two numbers N and M .
T≤1000 , 1≤N≤1000000 , 1≤M≤263 .
Be careful to the range of M.
You'd better print the enter in the last line when you hack others.
You'd better not print space in the last of each line when you hack others.
Output
For each test case,output an answer.
Sample Input
3 1 1 1 2 2 4
Sample Output
0 -1 1
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
using namespace std;
unsigned long long gcd(unsigned long long a,unsigned long long b){
return b==0?a:gcd(b,a%b);
}
int main()
{
int t;
unsigned long long n,m;
scanf("%d",&t);
while(t--){
scanf("%lld%lld",&n,&m);
if(n==m){
printf("0\n");
}
else if(n>m){
printf("-1\n");
}
else {
int cnt=0;
while(n!=m){
unsigned long long num=gcd(n,m/n);
if(num==1)break;
n=n*num;
cnt++;
}
if(n==m){
printf("%d\n",cnt);
}
else {
printf("-1\n");
}
}
}
return 0;
}