HDOJ 5505 GT and numbers

GT and numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1237    Accepted Submission(s): 319


Problem Description
You are given two numbers  N  and  M .

Every step you can get a new  N  in the way that multiply  N  by a factor of  N .

Work out how many steps can  N  be equal to  M  at least.

If N can't be to M forever,print  1 .
 

Input
In the first line there is a number  T . T  is the test number.

In the next  T  lines there are two numbers  N  and  M .

T1000 1N1000000 , 1M263 .

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.
 

Output
For each test case,output an answer.
 

Sample Input
  
  
3 1 1 1 2 2 4
 

Sample Output
  
  
0 -1 1
 

Source
 
题解: 
首先, 如果n不能整除m, 或者n==1且m!=1, 肯定不能到达
然后, 如果让n到达m, 肯定要乘以(m/n), 设 x = m / n, 那么我们肯定要担心选择, 每次选择最大的, 那么就是gcd(n, x)
然后不断变换设t = gcd(n, x), 每次 n *= t, x /= t, 当gcd(n, x) == 1的时候终止, 这时候如果t != 1, 那么就是不能除尽,
比如说n = 3, m = 6的情况, 最后 t = 2, 肯定不能到达, 输出-1, 否则, 就是最终的结果了.



#include <cstdio>
#include <cstring>

typedef unsigned long long ULL;

ULL gcd(ULL n, ULL m) {
	return m == 0 ? n : gcd(m, n % m);
}

int main() {
	int T;
	scanf("%d", &T);

	while (T--) {
		ULL n, m;

		scanf("%llu%llu", &n, &m);
		if (m % n || (n == 1 && m != 1)) {
			puts("-1");
			continue;
		}

		ULL ans = 0;

		ULL tmp = m / n;
		while (tmp != 1) {
			ULL t = gcd(n, tmp);
			if (t == 1) break;
			n *= t;
			tmp /= t;
			++ans;
		}

		if (tmp != 1)
			puts("-1");
		else
			printf("%llu\n", ans);
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值