hdoj5183Negative and Positive (NP)【set】

Negative and Positive (NP)

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3233    Accepted Submission(s): 871


Problem Description
When given an array  (a0,a1,a2,an1)  and an integer  K , you are expected to judge whether there is a pair  (i,j)(0ij<n)  which makes that  NPsum(i,j)  equals to  K  true. Here  NPsum(i,j)=aiai+1+ai+2++(1)jiaj
 

Input
Multi test cases. In the first line of the input file there is an integer  T  indicates the number of test cases.
In the next  2T  lines, it will list the data for each test case.
Each case occupies two lines, the first line contain two integers  n  and  K  which are mentioned above.
The second line contain  (a0,a1,a2,an1) separated by exact one space.
[Technical Specification]
All input items are integers.
0<T25,1n1000000,1000000000ai1000000000,1000000000K1000000000
 

Output
For each case,the output should occupies exactly one line. The output format is Case #id: ans, here id is the data number starting from 1; ans is “Yes.” or “No.” (without quote) according to whether you can find  (i,j)  which makes  PNsum(i,j)  equals to  K .
See the sample for more details.
 

Sample Input
  
  
2 1 1 1 2 1 -1 0
 

Sample Output
  
  
Case #1: Yes. Case #2: No.
Hint
If input is huge, fast IO method is recommended.
 

Source

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<queue>
#include<vector>
#include<set>
using namespace std;
const int maxn=1000010;
long long num[maxn];
set<long long >S;
int main()
{
    int t,i,j,test=1;
    long long n,k;
    scanf("%d",&t);
    while(t--){
        scanf("%lld%lld",&n,&k);
        for(i=1;i<=n;++i){
            scanf("%lld",&num[i]);
            if(i&1)
                num[i]=num[i-1]+num[i];
            else 
                num[i]=num[i-1]-num[i];
        }
        S.clear();
        bool sign=false;
        for(i=n;i>=0;--i){
            if(i&1){
                if(S.find(num[i]-k)!=S.end()){
                    sign=true;break;
                }
            }
            else {
                if(S.find(num[i]+k)!=S.end()){
                    sign=true;break;
                }
            }
            S.insert(num[i]); 
        }
        printf("Case #%d: ",test++);
        if(sign){
            printf("Yes.\n");
        }
        else {
            printf("No.\n");
        }
        
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值