hdoj5276GCD

GCD

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1135    Accepted Submission(s): 352


Problem Description
Give you a sequence of  N(N100,000)  integers :  a1,...,an(0<ai1000,000,000) . There are  Q(Q100,000)  queries. For each query  l,r  you have to calculate  gcd(al,,al+1,...,ar)  and count the number of pairs (l,r)(1l<rN) such that  gcd(al,al+1,...,ar)  equal  gcd(al,al+1,...,ar) .
 

Input
The first line of input contains a number  T , which stands for the number of test cases you need to solve.

The first line of each case contains a number  N , denoting the number of integers.

The second line contains  N  integers,  a1,...,an(0<ai1000,000,000) .

The third line contains a number  Q , denoting the number of queries.

For the next  Q  lines, i-th line contains two number , stand for the  li,ri , stand for the i-th queries.
 

Output
For each case, you need to output “Case #:t” at the beginning.(with quotes,  t  means the number of the test case, begin from 1).

For each query, you need to output the two numbers in a line. The first number stands for  gcd(al,al+1,...,ar)  and the second number stands for the number of pairs (l,r)  such that  gcd(al,al+1,...,ar)  equal  gcd(al,al+1,...,ar) .
 

Sample Input
  
  
1 5 1 2 4 6 7 4 1 5 2 4 3 4 4 4
 

Sample Output
  
  
Case #1: 1 8 2 4 2 4 6 1
 

Author
HIT
 

Source


想到了用dp快速求区间的gcd值但第二个值却不知道怎么求, 我们注意观察 gcd(a_{l},a_{l+1},...,a_{r})gcd(al,al+1,...,ar) ,当l固定不动的时候, r=l...nr=l...n 时,我们可以容易的发现,随着 rr 的増大, gcd(a_{l},a_{l+1},...,a_{r})gcd(al,al+1,...,ar) 是递减的,同时 gcd(a_{l},a_{l+1},...,a_{r})gcd(al,al+1,...,ar) 最多 有 log\ 1000,000,000log 1000,000,000 个不同的值,为什么呢?因为 a_{l}al 最多也就有 log\ 1000,000,000log 1000,000,000 个质因数。因此对第二个数二分求出map记录即可。
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<list>
#include<map>
#include<vector>
using namespace std;
const int maxn=1010010;
int dp[maxn][31],n;
map<int,long long>cnt;
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
void init(){
    int i,j;
    for(j=1;j<=log2(n+1);++j){
        for(i=1;i<=n-(1<<j)+1;++i){
            dp[i][j]=gcd(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
        }
    }
}
int query(int l,int r){
    int k=log2(r-l+1);
    return gcd(dp[l][k],dp[r-(1<<k)+1][k]);

}
int main()
{
    int t,test=1;cin>>t;
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n;++i){
            scanf("%d",&dp[i][0]);
        }init();cnt.clear();
        for(int i=1;i<=n;++i){
            int left=i,right=n;
            while(left<=right){
                int num=query(i,left),ans=left,pos=left;
                while(left<=right){
                    int mid=(left+right)>>1;
                    if(query(i,mid)<num){
                        right=mid-1;
                    }
                    else {
                        ans=mid;left=mid+1;
                    }
                }
                cnt[num]+=(long long)(ans-pos+1);
                left=ans+1;right=n;
            }
        }
        int q;cin>>q;
        printf("Case #%d:\n",test++);
        while(q--){
            int l,r;
            scanf("%d%d",&l,&r);
            int ans=query(l,r);
            printf("%d %lld\n",ans,cnt[ans]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值