poj3295 -- Tautology--构造法

4 篇文章 0 订阅

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not


输入由p、q、r、s、t、K、A、N、C、E共10个字母组成的逻辑表达式,

其中p、q、r、s、t的值为1(true)或0(false),即逻辑变量;

K、A、N、C、E为逻辑运算符,

K --> and:  x && y

A --> or:  x || y

N --> not :  !x

C --> implies :  (!x)||y

E --> equals :  x==y

问这个逻辑表达式是否为永真式。

PS:输入格式保证是合法的

思路: 32的循环,利用栈的思想,如果有一种情况是假的,那么不是永真;

原来感觉好难,看到网上的代码,太麻烦,和难理解,后来问了一下,就敲出来了,挺简单的,不知道为啥他们敲的这么长

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int K[2][2]= {0,0,0,1}, A[2][2]= {0,1,1,1},N[2] = {1,0},C[2][2] = {1,1,0,1},E[2][2]= {1,0,0,1};
char ls[150];
int p,q,r,s,t;
bool cont ;
void op()
{
    int a[150],k = 0;
    int str = strlen(ls),i;
    for(i = str-1; i >= 0; i--)
    {
        if(ls[i] == 'p')
            a[k++] = p;
        else  if(ls[i] == 'q')
            a[k++] = q;
        else  if(ls[i] == 'r')
            a[k++] = r;
        else  if(ls[i] == 's')
            a[k++] = s;
        else  if(ls[i] == 't')
            a[k++] = t;
         else if(ls[i] == 'K')
         {
                int mm = K[a[k-1]][a[k-2]];
                a[k-2] = mm;
                k--;
         }
         else if(ls[i] == 'A')
         {
                 int mm = A[a[k-1]][a[k-2]];
                 a[k-2] = mm;
                 k--;
         }
         else if(ls[i] == 'N')
         {
                 a[k-1] = N[a[k-1]];
         }
         else if(ls[i] == 'C')
         {
                 int mm = C[a[k-1]][a[k-2]];
                 a[k-2] = mm;
                 k--;
         }
         else if(ls[i] == 'E')
         {
                 int mm = E[a[k-1]][a[k-2]];
                 a[k-2] = mm;
                 k--;
         }
    }
    if(a[0] == 0)
        cont = false;
}
int main()
{
    while(~scanf("%s",ls) && ls[0]!='0')
    {
        cont = true;
        for(p = 0; p < 2; p++)
            for(q = 0; q < 2; q++)
                for(r = 0; r< 2; r++)
                    for(s = 0; s < 2; s++)
                        for(t = 0; t < 2; t++)
                        {
                            op();
                        }
        if(cont)
            printf("tautology\n");
        else
            printf("not\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值