POJ 3295:Tautology:恒真命题的判断

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8965 Accepted: 3427

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source

首先生成p、q、r、s、t的全排列(不一定包含所有元素),将全排列带入命题中求出结果。在分析命题中,采用逆序查看和栈存储的方式计算命题的结果。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
char a[105];
int result,use[7],usenum,b[105];
void init()
{
	result=1;
	usenum=0;
	memset(use,-1,sizeof(use));
}
void isuse()
{
	int i,j;
	for(i=0;i<strlen(a);i++)
	{
		if(a[i]>90)
		{
			if(use[a[i]-'p']==-1)
				usenum++;
			use[a[i]-'p']=0;
		}
	}
}
int next(int x)
{
	int i,j;
	for(i=x;i<5;i++)
		if(use[i]!=-1)
			break;
	return i;
}
void addone()
{
	int i,j;
	i=next(0);
	use[i]++;
}
void shengcheng()
{
	int i,j;
	i=next(0);
	while(i<5)
	{
		if(use[i]==2)
		{
			use[i]=0;
			i=next(i+1);
		    if(i<5)
			use[i]++;
		}
		else
			break;
	}
}
int panduan()
{
	int i,j,pp=0;
	int res;
	int ta,tb;
	for(i=strlen(a)-1;i>=0;i--)
	{
		if(a[i]>90)
			b[pp++]=use[a[i]-'p'];
		else
		{
			switch(a[i])
			{
			case'K':
				ta=b[--pp];
				tb=b[--pp];
				b[pp++]=ta&tb;
				break;
			case'A':
				ta=b[--pp];
				tb=b[--pp];
				b[pp++]=ta|tb;
				break;
			case'C':
				ta=b[--pp];
				tb=b[--pp];
				b[pp++]=(!tb)|ta;
				break;
			case'E':
				ta=b[--pp];
				tb=b[--pp];
				b[pp++]=(ta&tb)|(!(ta|tb));
				break;
			case'N':
				ta=b[--pp];
				b[pp++]=!ta;
				break;
			default:break;
			}
		}
	}
	return b[0];
}
int main()
{
	int i,j;
	while(scanf("%s",a)!=EOF&&a[0]!='0')
	{
		init();
		isuse();
		for(i=0;i<pow(2,(double)usenum);i++)
		{
			shengcheng();
			if(!panduan())
			{
				result=0;
				break;
			}
			addone();
		}
		if(result)
			printf("tautology\n");
		else
			printf("not\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值