集训队专题(1)1003 Phone List

Phone List

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 59   Accepted Submission(s) : 22
Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)
 

       题目大意:给你几组电话号码,问你存不存在一个电话号码是另一个电话号码的前缀,如果有,则输出“NO”,否则输出“YES”,如样例1中911为91125426的前缀,所以输出“NO”。

       在这里小编用数组模拟去实现,当然也可以用指针去实现(小编没试过,不知道会不会爆内存~)。

       这里判断的条件还是有点坑,首先样例具有迷惑性,样例的前缀词出现在前面,所以很多人的判断条件都是只判断了最新建立的节点在之前建立的节点里是否存在前缀,但往往忽略了有可能前缀词在后面出现(别问小编怎么知道的,因为小编也是这样莫名其妙的WA了很多次TT)。判断新建立的节点是否是已建立的节点的前缀,只需要判断是否有新节点的出现即可。

#include <string>
#include <cstring>
#include <cstdio>
#include <iostream>
using namespace std;
struct node
{
	bool end;//判断是否为号码的最后一位 
	int a[10];
};
bool x;
int ptr;
node list[100000];
void Init()
{
	x = true;
	ptr = 0;
	for(int i=0; i<100000; i++)
	{
		list[i].end = false;
		for(int j=0; j<10; j++)
			list[i].a[j] = -1;
	}
}
void Insert(char *s)
{
	bool z=false;
	bool y=false;
	int now=0;
	int len=strlen(s);
	for(int i=0; i<len; i++)
	{
		if(list[now].a[s[i]-'0'] == -1)
		{
			z = true;
			list[now].a[s[i]-'0'] = ++ptr;
			now = ptr;
		}
		else
		{
			now = list[now].a[s[i]-'0'];
			if(list[now].end) y = true;
		}
	}
	list[now].end = true;
	x=(!y)&&z;
}
int main()
{
	int t,n;
	char s[11];
	scanf("%d",&t);
	while(t--)
	{
		Init();
		scanf("%d",&n);
		while(n--)
		{
			scanf("%s",s);
			if(x) Insert(s);
		}
		if(x) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值