集训队专题(5.2)1005 The Stable Marriage Problem

The Stable Marriage Problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 608    Accepted Submission(s): 305


Problem Description
The stable marriage problem consists of matching members of two different sets according to the member’s preferences for the other set’s members. The input for our problem consists of:

a set M of n males;
a set F of n females;

for each male and female we have a list of all the members of the opposite gender in order of preference (from the most preferable to the least).
A marriage is a one-to-one mapping between males and females. A marriage is called stable, if there is no pair (m, f) such that f ∈ F prefers m ∈ M to her current partner and m prefers f over his current partner. The stable marriage A is called male-optimal if there is no other stable marriage B, where any male matches a female he prefers more than the one assigned in A.

Given preferable lists of males and females, you must find the male-optimal stable marriage.

 

Input
The first line gives you the number of tests. The first line of each test case contains integer n (0 < n < 27). Next line describes n male and n female names. Male name is a lowercase letter, female name is an upper-case letter. Then go n lines, that describe preferable lists for males. Next n lines describe preferable lists for females.

 

Output
For each test case find and print the pairs of the stable marriage, which is male-optimal. The pairs in each test case must be printed in lexicographical order of their male names as shown in sample output. Output an empty line between test cases.

 

Sample Input
  
  
2 3 a b c A B C a:BAC b:BAC c:ACB A:acb B:bac C:cab 3 a b c A B C a:ABC b:ABC c:BCA A:bac B:acb C:abc
 

Sample Output
  
  
a A b B c C a B b A c C
 

Source
 

此题也是一个裸的稳定婚姻问题,也没什么好说的,直接看代码就好了

#include <cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=50;
int g[maxn][maxn],b[maxn][maxn],visit[maxn][maxn];
int bf[maxn],gf[maxn];
char ch[maxn],str[maxn];
map<char,int> G,M;
map<int,char> GG,MM;
queue<int> q;
int T,n;
void init()
{
	G.clear(),M.clear(),GG.clear(),MM.clear();
	memset(visit,0,sizeof(visit));
	memset(bf,0,sizeof(bf));
	while(!q.empty()) q.pop();
}
void find(int x)
{
	for(int i=n; i>=1; i--)
	{
		if(visit[x][i]) continue;
		visit[x][i] = 1;
		int y=b[x][i];
		if(!bf[y])
		{
			bf[y] = x;
			gf[x] = y;
			return;
		}
		else
		{
			if(g[y][x] > g[y][ bf[y]] )
			{
				q.push(bf[y]);
				bf[y] = x;
				gf[x] = y;
				return;
			}
		}
	}
}
void Gale_Shapley()
{
	for(int i=1; i<=n; i++) q.push(i);
	while(!q.empty())
	{
		int x=q.front();
		q.pop();
		find(x);
	}
	sort(ch+1,ch+n+1);
	for(int i=1; i<=n; i++)
	{
		printf("%c %c\n",ch[i],MM[gf[ G[ ch[i] ] ]]);
	}
}
int main()
{
	cin >> T;
	while(T--)
	{
		cin >> n;
		init();
		for(int i=1; i<=n; i++)
		{
			cin >> ch[i];
			G[ch[i]] = i;
			GG[i] = ch[i];
		}
		for(int i=1; i<=n; i++)
		{
			cin >> ch[n+i];
			M[ch[n+i]] = i;
			MM[i] = ch[i+n];
		}
		for(int i=1; i<=n; i++)
		{
			scanf("%s",str+1);
			int x=G[str[1]];
			for(int j=3; j<=n+2; j++)
			{
				int y=M[str[j]];
				b[x][n-j+3] = y;
			}
		}
		for(int i=1; i<=n; i++)
		{
			scanf("%s",str+1);
			int x=M[str[1]];
			for(int j=3; j<=n+2; j++)
			{
				int y=G[str[j]];
				g[x][y] = n-j+3;
			}
		}
		Gale_Shapley();
		if(T) puts("");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值