集训队专题(6)1006 Girls and Boys

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9536    Accepted Submission(s): 4363


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
 

Source
 

此题的题意很明确,男女搭配,很容易想到的是以男女作为两个集合来进行二分图建图,但这题很奇怪,在给出关系的时候并没有给出性别……起初小编是想把第一个出现的人物作为男性,后根据关系来确定男女,但是实际上这样难免会导致一些人没有办法确定男女。小编看了别人的题解的方法,大神们是讲一个人看做又是男的又是女的,然后组合完之后求出最大匹配,再除以2,得到之前的最大匹配。这样做其实有道理,只需要关注其关系,并不需要关注其性别,因为多出场了一倍的任务,所以会出现重复,再除以2即可得到原图的最大匹配。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000+10;
int uN,vN;
int g[maxn][maxn],linker[maxn];
bool used[maxn];
bool dfs(int u)
{
	int v;
	for(v=0; v<vN; v++)
		if(g[u][v] && !used[v])
		{
			used[v] = true;
			if(linker[v]==-1 || dfs(linker[v]))
			{
				linker[v] = u;
				return true;
			}
		}
	return false;
}
int hungary()
{
	int res = 0;
	int u;
	memset(linker,-1,sizeof(linker));
	for(u=0; u<uN; u++)
	{
		memset(used,0,sizeof(used));
		if(dfs(u)) res++;
	}
	return res;
}
int main()
{
	int n,u,v,num;
	while(scanf("%d",&n)!=EOF)
	{
		memset(g,0,sizeof(g));
		for(int i=0; i<n; i++)
		{
			scanf("%d: (%d)",&u,&num);
			for(int j=0; j<num; j++)
			{
				scanf("%d",&v);
				g[u][v] = 1;
			}
		}
		uN = vN = n;
		int ans = hungary();
		printf("%d\n",n-ans/2);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值