华中农业大学第四届程序设计大赛网络同步赛 Arithmetic Sequence

题目链接:http://acm.hzau.edu.cn/problem.php?cid=1009&pid=9

Problem J: Arithmetic Sequence

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 1823   Solved: 317
[ Submit][ Status][ Web Board]

Description

    Giving a number sequence A with length n, you should choosing m numbers from A(ignore the order) which can form an arithmetic sequence and make m as large as possible.

Input

   There are multiple test cases. In each test case, the first line contains a positive integer n. The second line contains n integers separated by spaces, indicating the number sequence A. All the integers are positive and not more than 2000. The input will end by EOF.

Output

   For each test case, output the maximum  as the answer in one line.

Sample Input

5
1 3 5 7 10
8
4 2 7 11 3 1 9 5

Sample Output

4
6

HINT

   In the first test case, you should choose 1,3,5,7 to form the arithmetic sequence and its length is 4.


   In the second test case, you should choose 1,3,5,7,9,11 and the length is 6.



题意很简单,给我们一个序列,问我们从这个序列中选出一些数能构成的最长的等差序列的长度为多少。

这个问题我们用DP来解决,首先因为我们取数是不用关注它的顺序的,所以我们就可以先排个序,然后我们用dp[i][j]表示取到第i个数的时候间距为j的长度的等差数列最长的长度,所以我们有状态转移方程dp[i][dif] = dp[j][dif]+1

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 2000+5;
int a[maxn];
int dp[maxn][maxn];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0; i<n; i++) scanf("%d",&a[i]);
		if(n <= 1)
		{
			printf("%d\n",n);
			continue;
		}
		sort(a,a+n);
		int ans = 1;
		for(int i=0; i<maxn; i++)
			for(int j=0; j<maxn; j++)
				dp[i][j] = 1;
		for(int i=1; i<n; i++)
		{
			for(int j=0; j<i; j++)
			{
				int dif = a[i]-a[j];
				dp[i][dif] = dp[j][dif]+1;
				ans = max(ans, dp[i][dif]);
			}
		}
		//for(int i=0; i<n; i++) printf("%d ",dp[i][0]);
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值