最短路 Invitation Cards POJ - 1511

题目:

Invitation Cards
Time Limit: 8000MS Memory Limit: 262144K
Total Submissions: 30192 Accepted: 10077

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题意:一共N组case。每一个case第一行输入图的点数p,边数q。之后q行输入每个单向边的信息(起点,终点,权值)。求编号为1的点到其他各点的最短路之和+其他各点到编号为1的点的最短路之和。

思路:方法就是跑两次Dijkstra。第一次跑求出1到其他点的最短路之和。第二次求其他各点到编号为1的点的最短路,方法就是把图中的所有边反向,然后再求1到其他点的最短路。推导过程可以理解为跑dijkstra的时候,更新的是以当前点为终点的最短路径,那我们不妨把图中所有的边都换一个方向,还按最普通的dijkstra跑就可以啦^-^

坑点:之前一直卡时间,最后用链式前向星才搞过去,,也不知道有没有人能用邻接表卡过去。。。。算了反正做出来了=。=

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<stack>
#define sd(x) scanf("%d",&x)
#define ss(x) scanf("%s",x)
#define sc(x) scanf("%c",&x)
#define sf(x) scanf("%f",&x)
#define slf(x) scanf("%lf",&x)
#define slld(x) scanf("%lld",&x)
#define me(x,b) memset(x,b,sizeof(x))
#define pd(d) printf("%d\n",d);
#define plld(d) printf("%lld\n",d);
// #define Reast1nPeace

using namespace std;

typedef long long ll;
const int INF = 0x3f3f3f3f;
const int MAXN = 1000010;

int p,q;

int head[MAXN];
int ophead[MAXN];
struct edge{
	int to;
	int weight;
	int nxt; 
}G[MAXN] , opG[MAXN];


int dis[MAXN];
int opdis[MAXN];
bool vis[MAXN];
bool opvis[MAXN];

struct node{
	int p;
	int len;
	node(int p , int len){
		this->p = p;
		this->len = len;
	}
	friend bool operator< (node f1, node f2){
		if(f1.len != f2.len)
			return f1.len > f2.len;
        return f1.p > f2.p; 
	}
};

ll dijkstra(){
	priority_queue<node> q1,q2;
	memset(dis,INF,sizeof(dis));
	memset(opdis,INF,sizeof(opdis));
	memset(vis,0,sizeof(vis));
	memset(opvis,0,sizeof(opvis));
	
	dis[1] = opdis[1] = 0;
	q1.push(node(1,0));
	while(!q1.empty()){
		node now = q1.top(); q1.pop();
		
		vis[now.p] = 1;
		
		for(int i = head[now.p] ; i!=0 ; i = G[i].nxt){
			int nxt = G[i].to;
			int len = G[i].weight;
			if(!vis[nxt] && dis[nxt]> dis[now.p]+len){
				dis[nxt] = dis[now.p]+len;
				q1.push(node(nxt,dis[nxt]));    
			}
		}
	}

	q2.push(node(1,0));
	while(!q2.empty()){
		node now = q2.top(); q2.pop();
		
		opvis[now.p] = 1;
		
		for(int i = ophead[now.p] ; i!=0 ; i = opG[i].nxt){
			int nxt = opG[i].to;
			int len = opG[i].weight;
			if(!opvis[nxt] && opdis[nxt]> opdis[now.p]+len){
				opdis[nxt] = opdis[now.p]+len;
				q2.push(node(nxt,opdis[nxt]));
			}
		}
	}

	ll ans = 0;
	for(int i = 1 ; i<=p ; i++){
		ans += dis[i];
		ans += opdis[i];
	}

	return ans;
}


int main(){
	int t;
	int s,e,w;
	scanf("%d",&t);
	while(t--){
		memset(head,0,sizeof(head));
		memset(ophead,0,sizeof(ophead));
		memset(G,0,sizeof(G));
		memset(opG,0,sizeof(opG));

		scanf("%d %d",&p,&q);
		
		for(int i = 1 ; i<=q ; i++){
			scanf("%d %d %d",&s,&e,&w);
			G[i].to = e; G[i].weight = w;
			G[i].nxt = head[s];
			head[s] = i;
			
			opG[i].to = s; opG[i].weight = w;
			opG[i].nxt = ophead[e];
			ophead[e] = i;
		}
		printf("%lld\n",dijkstra());
	} 
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值