A1037 Magic Coupon (25分)【C语言】

A1037 Magic Coupon (25分)【C语言】

原题链接

将两个数组进行排序,

  1. 正序判断两个数组的值是否都为负;
  2. 逆序判断两个数组的值是否都为正;

因为排序后,绝对值最大的负数在数组前端,最大的正数在数组的后端,二者相乘即可得最优。

题目描述:
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

输入格式:
Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​C​​ ,N​P​​ ≤10 ​5​​ , and it is guaranteed that all the numbers will not exceed 2 ​30​​ .

输出格式:
For each test case, simply print in a line the maximum amount of money you can get back.

输入样例:

4
1 2 4 -1
4
7 6 -2 -3

输出样例:

43

实现代码:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;

int main()
{
	int Nc, Np, i, j;
	int coupon[maxn], product[maxn];
	scanf("%d", &Nc);
	for(i=0; i<Nc; ++i){
		scanf("%d", &coupon[i]);
	}
	scanf("%d", &Np);
	for(i=0; i<Np; ++i){
		scanf("%d", &product[i]);
	}
	sort(coupon, coupon+Nc);
	sort(product, product+Np);
	int ans=0;
	for(i=0; i<Nc&&i<Np&&coupon[i]<0&&product[i]<0; ++i){
		ans += coupon[i] * product[i];
	}
	for(i=Nc-1, j=Np-1; i>=0&&j>=0&&coupon[i]>0&&product[j]>0; i--, j--){
		ans += coupon[i] * product[j];
	}
	printf("%d", ans);
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值