1037 Magic Coupon (25 point(s))
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1 ≤ NC, NP ≤ 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
题目大意:
有 NC 张优惠券,每张券有不同数字,有 NP 种产品,每种产品有不同价值;优惠券数字乘产品价值即金币数;
可以从两个序列中选相同数目的元素,一对一相乘,求可得金币的最大值;
设计思路:
贪心算法:
- 分别对两个序列按相同顺序排序,这里是从小到大的顺序
- 前面都是负数的元素相乘,后面都是正数的元素相乘,累计求和,即为最大值
编译器:C (gcc)
#include <stdio.h>
int cmp(const void *a, const void *b)
{
int *n1 = (int *)a, *n2 = (int *)b;
return *n1 - *n2;
}
int main(void)
{
int nc, np;
int coupon[100000] = {0}, product[100000] = {0};
int i, p, q, sum;
scanf("%d", &nc);
for (i = 0; i < nc; i++) {
scanf("%d", &coupon[i]);
}
scanf("%d", &np);
for (i = 0; i < np; i++) {
scanf("%d", &product[i]);
}
qsort(coupon, nc, sizeof(coupon[0]), cmp);
qsort(product, np, sizeof(product[0]), cmp);
sum = 0;
p = 0;
q = 0;
while (p < nc && q < np && coupon[p] < 0 && product[q] < 0) {
sum += coupon[p] * product[q];
p++;
q++;
}
p = nc - 1;
q = np - 1;
while (p >= 0 && q >= 0 && coupon[p] > 0 && product[q] > 0) {
sum += coupon[p] * product[q];
p--;
q--;
}
printf("%d", sum);
return 0;
}