树状数组模板+poj1195(二维树状数组)

感谢学长的博客~~http://blog.csdn.net/lin375691011/article/details/21247409

在数组长度为n的树状数组中:

寻找下一个需要添加的数的下标:

int lowbit(int x)  
{  
    return x&(-x);  
}  
一维树状数组更新是这样的:

void add(int x,int val)  
{  
    for(;x<=n;x+=lowbit(x))  
    {  
        num[x]+=val;  
    }  
}  
二维树状数组更新是这样的:

void  add(int x,int y,int val)  
{  
    for(int i=x;i<=s;i+=lowbit(i))  
    {  
        for(int j=y;j<=s;j+=lowbit(j))  
        {  
            num[i][j]+=val;  
        }  
    }  
}  

一维树状数组查询是这样的:

int query(int x)  
{  
    int ans=0;  
    for(;x>0;x-=lowbit(x))  
    {  
        ans+=c[i];  
    }  
    return ans;  
}  
二维树状数组查询是这样的

int query(int x,int y)  
{  
    int ans=0;  
    for(int i=x;i>0;i-=lowbit(i))  
    {  
        for(int j=y;j>0;j-=lowbit(j))  
        {  
            ans+=num[i][j];  
        }  
    }  
    return ans;  
}  

下面看一个纯二维的树状数组模板题


Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 18744 Accepted: 8647

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

题目大意:

给定矩阵大小,可以更新矩阵中的某些数,要求输出某个范围内的所有数之和。

#include<stdio.h>
#include<string.h>
#define lowbit(x) x&(-x)
#define maxn 1025
int c[maxn][maxn];
int n;
void add(int x,int y,int a)
{
    for( int i = x; i <=n; i += lowbit(i))
    {
        for( int j = y; j <=n; j += lowbit(j))
        {
            c[i][j]+=a;
        }
    }
}
int sum( int l,int r )
{
    int ans = 0;
    for( int i = l; i > 0; i -= lowbit(i) )
    {
        for( int j = r; j > 0; j -=lowbit(j))
        {

            ans+=c[i][j];
        }
    }
    return ans;
}
int main()
{
    int i,j,k;
    scanf("%d%d",&k,&n);
    memset(c,0,sizeof(c));
    int op;
    while(~scanf("%d",&op))
    {
        if(op>=3) break;
        if(op == 1)
        {
            int x,y,a;
            scanf("%d%d%d",&x,&y,&a);
            add(x+1,y+1,a);
        }

        else if(op == 2)
        {
            int l,r,b,t;
            scanf("%d%d%d%d",&l,&b,&r,&t);
            l++,b++,r++,t++;
            printf("%d\n",sum(r,t) - sum(r,b-1) -  sum(l-1, t) + sum(l-1, b-1));

        }
    }
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值