1020. Tree Traversals (25)已知后序中序 层次遍历

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
#include<cstdio>
#include<cstring>
#include <queue>
using namespace std;
struct node
{
    int data;
    struct node*l,*r;
};

struct node *creat(int *last, int * in, int n)
{
   struct node *root;
   for(int i = 0; i < n; i++)
   {
       if(in[i] == last[ n -1])
       {
          root = new node();
          root->data = in[i];
          root->l = creat(last, in, i );
          root->r = creat(last+i, in+i+1, n - i -1);
          return root;
       }
   }
   return NULL;
}
void bfs(node *root)
{
   queue<node*>q;
   q.push(root);
   int flag = 0;
   while(!q.empty())
   {
       node * u = q.front();
       q.pop();
       if(flag)
          printf(" ");
       flag = 1;
       printf("%d", u->data);
       if(u->l)
       {
           q.push(u->l);
       }
       if(u->r)
       {
          q.push(u->r);
       }
   }



}
int main()
{
   int n;
   scanf("%d", &n);
   int last[110];
   int in[110];
   for(int i = 0; i < n; i++)
   {
       scanf("%d", &last[i]);
   }

     for(int i = 0; i < n; i++)
   {
       scanf("%d", &in[i]);
   }
   struct node *root = new node();
   root = creat(last, in, n);
   bfs(root);

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值