【贪心算法】Cross the river

Problem description:

Some people want to cross a river by boat. Each person has a weight, and each boat can carry a maximum weight of limit. Each boat carries at most 2 people at the same time, provided the sum of the weight of those people is at most limit. Return the minimum number of boats to carry every given person. Note that it is guaranteed each person can be carried by a boat.

Input:

The input will be 3 lines. The first line is a single integer n (1 <= n <= 50000), which means the number of people. The second line is a single integer l (1 <= l <= 30000), represents the weight limit. And the last line contains n integers p_1, p_2, …, p_n (1 <= p_i <= l), separated by spaces, that represent people’s weights.

Output:

The output will consist of one line containing one integer, which represents the minimum number of boats.

Sample Input:

4
3
3 2 2 1

Sample Output:

3

原题地址:

UOJ#31

#include <iostream>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
class Solution {
public:
    int minimumBoats(int n, int limit, int persons[]) {
        sort(persons, persons + n);  // 从小到大排序
        // i从左到右,j从右到左
        for(int i = 0,j = n - 1;i <= j;j--){
            sum = persons[i] + persons[j];
            if(sum <= limit){
                numBoat++;
                i++;
            }else
                numBoat++;
        }
        return numBoat;
    }
private:
    int sum, numBoat = 0;  // 船的个数
};
int main(){
    int n, limit;
    cin >> n >> limit;
    int persons[n];
    for(int i = 0;i < n;i++)
        scanf("%d", &persons[i]);
    Solution sol;
    cout<<sol.minimumBoats(n, limit, persons)<<endl;
    return 0;
}

在这里插入图片描述

评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

SL_World

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值