(POJ 3080)Blue Jeans 枚举 + KMP

Blue Jeans
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16889 Accepted: 7493
Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
m lines each containing a single base sequence consisting of 60 bases.
Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string “no significant commonalities” instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT
Sample Output

no significant commonalities
AGATAC
CATCATCAT
Source

South Central USA 2006

题意:
求n个字符串的最长公共子串,若有多个,则输出字典序最小的。

分析:
枚举第一个串的所以子串(从长到短,若已经有长的了就不用再枚举短的了),用KMP算法去匹配剩下的每个串。寻找字典序最小的我们可以用strcmp()函数解决。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;

char str[11][65],ans[65];
int f[65];

void getFail(char* P,int* f)
{
    int m = strlen(P);
    f[0]=f[1]=0;
    for(int i=1;i<m;i++)
    {
        int j = f[i];
        while(j && P[i]!=P[j]) j=f[j];
        f[i+1]=P[i]==P[j]?j+1:0;
    }
}

bool KMP(char* T,char* P,int* f)
{
    int n=strlen(T),m=strlen(P);
    getFail(P,f);
    int j=0;
    for(int i=0;i<n;i++)
    {
        while(j && T[i]!=P[j]) j=f[j];
        if(T[i]==P[j]) j++;
        if(j==m) return true;
    }
    return false;
}

int main()
{
    int t,n,m;
    bool flag=false;
    char tmp[65];
    scanf("%d",&t);
    while(t--)
    {
        flag=false;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",str[i]);
        }
        for(int i=60;i>=3 && flag==false;i--)//所有长度,从长到短
        {
           for(int j=0;j+i<=60;j++)//枚举子串
           {
               strncpy(tmp,str[0]+j,i);//strcmp()不复制‘\0'
               tmp[i]='\0';
               int k;
               for(k=1;k<n;k++)
               {
                   if(!KMP(str[k],tmp,f)) break;
               }
               if(k>=n)
               {
                   if(!flag)
                   {
                       flag=true;
                       strcpy(ans,tmp);
                   }
                   else
                   {
                       if(strcmp(ans,tmp)>0)
                        strcpy(ans,tmp);
                   }
               }
           }
        }
        if(flag) printf("%s\n",ans);
        else printf("no significant commonalities\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值