(POJ1961)Period <KMP算法求最小循环节>

Period
Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input

3
aaa
12
aabaabaabaab
0
Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
Source

Southeastern Europe 2004

题意:
给你一个长度为n的字符串s,求他的每一个前缀的最短循环节。当循环次数大于1时,输出i,k。i表示前i个字符组成的前缀,k为循环次数。

分析:
KMP算法中,f[i]数组存的是[0,i)的最长真前缀等于最长真后缀的长度。那么若前i个字符组成的前缀是循环的,那么i%(i-f[i])==0 一定成立。 错位部分就是循环节。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1000010;
char s[maxn];
int n,f[maxn];

void getfail(char* p)
{
    f[0] = 0; f[1] = 0;
    for(int i=1;i<n;i++)
    {
        int j = f[i];
        while(j && p[i] != p[j]) j = f[j];
        f[i+1] = p[i]==p[j] ? j+1 : 0;
    }
}

int main()
{
    scanf("%d",&n);
    int kase = 1;
    while(scanf("%d",&n)!=EOF && n)
    {
        scanf("%s",s);
        getfail(s);
        printf("Test case #%d\n",kase++);
        for(int i=2;i<=n;i++)
        {
            if(f[i] > 0 && i%(i-f[i])==0)
                printf("%d %d\n",i,i/(i-f[i]));
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值