(POJ1195)Mobile phones <二维树状数组>

Mobile phones
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.
这里写图片描述
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input

0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3
Sample Output

3
4
Source

IOI 2001

题意:
给你一个s*s的网格。可以做如下操作:
0 s : 将s*s的网格全被初始化为0
1 x y A : 将(x,y)处加A
2 x1,y1,x2,y2 : 问 x1<= x <= x2 y1<= y <= y2 的矩形内的所有格子的数之和,并输出
3 : 输入结束

分析:
题目要我们求一个网格中某小矩形框内的数的和。由于之前写过一维树状数组的题目。立刻我就想将二维的表格转化为一维的,然后二维格点(x,y)转化为一维的((x-1)*s + y) 【下标出1开始】。但是WA了。。。后来画了画图就知道错了,因为从二维转化为一维以后就不再是一段连续的区间了。。。
所以我们要用二维的树状数组来解决此题。
二维相对于一维就是只是加了一层循环而已,相当于多个一维的纵向排放在一起。所以二维的Sum(x,y)求的是一个矩形的区域的和

注意:本题的输入下标是从0开始的。。。。坑

AC代码:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 1050;
int s[maxn][maxn];
int lowbit[maxn];
int n;

int sum(int x,int y)
{
    int res = 0;
    for(int i = x; i > 0; i -= lowbit[i])
    {
        for(int j = y; j > 0; j -= lowbit[j])
            res += s[i][j];
    }
    return res;
}

void add(int x,int y,int d)
{
    for(int i=x;i<=n;i+=lowbit[i])
        for(int j=y;j<=n;j+=lowbit[j])
            s[i][j] += d;

}


int main()
{
    int k,x,y,a;
    int x1,y1,x2,y2;
    for(int i=1;i<=maxn;i++)
        lowbit[i] = i&-i;
    while(1)
    {
        scanf("%d",&k);
        if(k == 3) break;
        else if(k == 0)
        {
            scanf("%d",&n);
            memset(s,0,sizeof(s));
        }
        else if(k == 1)
        {
            scanf("%d%d%d",&x,&y,&a);
            x++; y++;
            add(x,y,a);
        }
        else if(k == 2)
        {
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            x1++; y1++; x2++; y2++;
            int ans = sum(x2,y2) + sum(x1-1,y1-1) - sum(x1-1,y2) - sum(x2,y1-1);
            printf("%d\n",ans);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值