(HDU 5775)Bubble Sort <树状数组> 多校训练4

Bubble Sort
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i) for(int j=N,t;j>i;—j) if(P[j-1] > P[j]) t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

HintIn first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

Author
FZU

Source
2016 Multi-University Training Contest 4

题意:
给你一个n的某个全排列,现在进行冒泡排序,问你每个数到达的最左边和最右边的距离?

分析:
考虑一个位置上的数字c在冒泡排序过程的变化情况。c会被其后面比c小的数字各交换一次,之后c就会只向前移动。
最左端:min(初始化位置,c)
最右端:max(初始化位置,初始化位置+后面比他小的数的个数)
我们的认为变成了求每个数后面比他小的数的个数是多少?这就是求逆序数的问题了。

我们用树状数组来完成:
注意要想清楚get(maxn)-get(V[i].second)的意思?
由于我们是按照递增的顺序更新数据,所以比c小的数一定会在c之前被更新,get(maxn)-get(V[i].second)是指比第i个数小,但是又出现在后面的位置的数的个数

时间复杂度O(n lg n)

AC代码:

#include<bits/stdc++.h>
using namespace std;

const int maxn = 100010;
int n,a[maxn],d[maxn];
int ans[maxn];

int lowbit(int x)
{
    return x&-x;
}

void update(int x)
{
    while(x <= maxn)//不能是<=n
    {
        d[x]++;
        x += lowbit(x);
    }
}

int get(int x)
{
    int ans = 0;
    while(x)
    {
        ans += d[x];
        x -= lowbit(x);
    }
    return ans;
}

int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(d,0,sizeof(d));
        vector<pair<int,int> > V;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            V.push_back(make_pair(a[i],i));
        }
        sort(V.begin(),V.end());
        for(int i=0;i<V.size();i++)
        {
            ans[i+1] = max(V[i].second,V[i].second+get(maxn)-get(V[i].second)) - min(V[i].second,i+1);
            update(V[i].second);
        }
        printf("Case #%d:",cas++);
        for(int i=1;i<=n;i++)
        {
            printf(" %d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值