[ PAT-A ] 1037 Magic Coupon (C++)

题目描述

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 10^5^, and it is guaranteed that all the numbers will not exceed 2^30^.

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43


解题思路

题目大意
两组序列中的元素,一一对应相乘,乘积之和最大为多少
思路
给两组序列排序,最大的正数之间相乘,最小的负数之间相称,其乘积之和必为最大


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
// zhicheng
// August 19,2018
vector<int> a;
vector<int> b;
int main()
{
    int np,nc,tmp,_;long long int sum=0;
    for(scanf("%d",&nc),_=nc;_;_--){scanf("%d",&tmp);a.push_back(tmp);}
    for(scanf("%d",&np),_=np;_;_--){scanf("%d",&tmp);b.push_back(tmp);}
    sort(a.begin(),a.end());
    sort(b.begin(),b.end());
    int p=0,c=0;
    while(p<np&&c<nc&&a[c]<0&&b[p]<0){sum+=a[c]*b[p];p++;c++;}// 最小的负数之间相称
    p=np-1;c=nc-1;
    while(p>=0&&c>=0&&a[c]>0&&b[p]>0){sum+=a[c]*b[p];p--;c--;}// 最大的正数之间相乘
    printf("%lld\n",sum);
    a.clear();b.clear();
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值