NYOJ - A+B Problem II

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include <stdio.h>
#include <string.h>

int main()
{
	int n,Case = 1,sign;
	char s1[1001],s2[1001]; 
	scanf("%d",&n);
	while(n--)
	{
		scanf("%s%s",s1,s2);
		int a[1001]={0},b[1001]={0},c[1001]={0};  
		int lenA = strlen(s1);
		int lenB = strlen(s2);
		for(int i = 0; i < lenA; i++)   // 将字符串转换为整数数组 
		{
			a[lenA-i-1] = s1[i] - '0';
		}
		for(int i = 0; i < lenB; i++)
		{
			b[lenB-i-1] = s2[i] - '0';
		}
		int m = lenA >= lenB?lenA:lenB;
		sign = 0;
		for(int i = 0; i < m; i++)         
		{   
		    int s = a[i] + b[i] + sign;    // sign为进位标志 
			if(s >= 10)
			{
				c[i] = s % 10;
				sign = 1;
			}
			else
			{
				c[i] = s;
				sign = 0;
			}
		}
		printf("Case %d:\n%s + %s = ",Case++,s1,s2);
		if(sign == 1)
		{
			printf("1");
		}
		for(int i = m-1; i >= 0; i--)
		{
			printf("%d",c[i]);
		}
		printf("\n");
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值