Spreading the Wealth (分金币)

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4
分析:
    设Xi表示第i个人给了i - 1的金币数,M表示最后每个人的金币数,Ai表示第i个人开始的金币数,那么:
    首先有:X1 = X1 + 0;
    然后,对于第一个人:A1 - x1 + x2 = M -> x2 = x1 - (A1 - M) = x1 - C1(令C1 = A1 - M)
          对于第二个人:A2 - x2 + x3 = M -> x3 = x2 - (A2 - M) = x1 - C2(C2 = C1 + A2 - M)
          对于第三个人:A3 - x3 + x4 = M -> x4 = x3 - (A3 - M) = x1 - C3(C3 = C2 + A3 - M)
          ....
          对于第n - 1个人:An-1 - Xn-1 + Xn = M -> Xn = Xn-1 - (An-1 - M) = x1 - Cn-1(Cn-1 = Cn-2 + An-1 - M)
          对于第n个人则不用考虑,已由第n-1个人推出了Xn。
所以题目变为求|x1| + |x1 + c[0]| + |x1 - c[1]| + ... + |x1 - c[n - 1]|的最小值。也就是在给定的数轴上求点x1到各个点和的最小值,那么容易证明这个点x1在中间部分。

代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 100001;
__int64 A[N],C[N],tot,M;//__int64代替long long
int  main()
{
	int n;
	while (scanf("%d",&n) == 1)//输入数据大,scanf比cin快
	{
		tot = 0;
		for (int i = 1; i <= n; i++)
		{
			scanf("%lld",&A[i]);
			tot += A[i];
		}
		M = tot / n;
		C[0] = 0;
		for (int k= 1; k < n; k++)//递推C数组
		{
			C[k] = C[k - 1] + A[k] - M;
		}
		sort(C,C + n);
		__int64 x1 = C[n / 2],ans = 0;//计算x1
		for (int j = 0; j < n; j++)
		{
			ans += abs(x1 - C[i]);
		}
		printf("%lld\n",ans);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值