关于虚拟原点

虚拟原点多用于图论中,就是再建一个点,使得他对于其他点的距离等于那个点的某一些特性,在用spfa算法求负环的时候要开一个虚拟原点,因为不能保证这个图是能通过一个点就能全走到的,spfa算法是设置一个起点,然后就是需要把这个起点设置成0号点,然后把其他的点都与这个点连接起来,这个边权就是这个点的属性,比如说这个点是起点的话,dis是0,所以0号点到这个点的距离就是0,下面来看一个题

Choose the best route

 One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n. 

Input

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

这个就是多个起点一个终点,这个就可以建一个虚拟原点,然后把每一个起点与这个虚拟原点的距离都设置成0,然后把这个虚拟原点设置成起点,然后求出这个点与终点的距离就行了,
下面看代码

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int inf=10000000;
int n,m,s;
int p[1001][1001];
int visit[1001];
int des[1001];
int dijkstra()
{
 int i,j,temp,k;
 memset(visit,0,sizeof(visit));
 for(i=0;i<=n;i++) des[i]=p[0][i];
 des[0]=0;
 visit[0]=1;
 for(i=0;i<=n;i++)
 {
  temp=inf;
  for(j=0;j<=n;j++)
  {
   if(visit[j]==0&&des[j]<temp)
   {
    temp=des[j];
    k=j;
   }
  }
  visit[k]=1;
  if(temp==inf) break;
  for(j=0;j<=n;j++)
  {
   if(visit[j]==0&&des[k]+p[k][j]<des[j]) des[j]=des[k]+p[k][j];
  }
 }
 return des[s];
}
int main()
{
 int a,b,c,mm,x,r,jk,i,j;
    while(scanf("%d %d %d",&n,&m,&s)!=EOF)
 {
  jk=10000000;
  for(i=0;i<=n;i++)
  {
   for(j=0;j<=n;j++)
   {
    p[i][j]=inf;
   }
  }
        for(i=1;i<=m;i++)
  {
   scanf("%d %d %d",&a,&b,&c);
   if(p[a][b]>c)
   {
    p[a][b]=c;
   }
  }
  scanf("%d",&mm);
  for(i=0;i<mm;i++)
  {
   scanf("%d",&x);
            p[0][x]=0;
  }
  jk=dijkstra();
  if(jk==10000000) puts("-1");
  else printf("%d\n",jk);
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

宇智波一打七~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值