UVA 116 Unidirectional TSP(DP+记忆化搜索)

Unidirectional TSP 
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu 
Submit Status Practice UVA 116 
Appoint description:

Description 
Download as PDF

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) – finding whether all the cities in a salesperson’s route can be visited exactly once with a specified limit on travel time – is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix “wraps” so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path’s weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6 
3 4 1 2 8 6 
6 1 8 2 7 4 
5 9 3 9 9 5 
8 4 1 3 2 6 
3 7 2 8 6 4 
5 6 
3 4 1 2 8 6 
6 1 8 2 7 4 
5 9 3 9 9 5 
8 4 1 3 2 6 
3 7 2 1 2 3 
2 2 
9 10 9 10

Sample Output

1 2 3 4 4 5 
16 
1 2 1 5 4 5 
11 
1 1 
19

【思路】

从左到右进行深搜,dp[i][j]记录第i行第j列到最后一列的最小代价,最后遍历dp[i][0],因为不超过10行,又要记录路径,所以下标可以暂且由0到m-1表示,用字符串数组route[i][j]维护从第i行到第j列到最后一列的路径,搜索过程中若采纳就加上它,最后把代表行号的字符加一打印出来就好了。还有这题行末不能有空格,无语。


【代码】

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int MAXN=102,MAXM=12;
const long long INF=0x3f3f3f3f3f3f3f3f;

int m,n;
int gra[MAXM][MAXN];
long long dp[MAXM][MAXN];
string route[MAXM][MAXN];

void dfs(int deep,int r)
{
    if(dp[r][deep]!=INF||deep==n-1)return;
    bool flag_up=false,flag_down=false;
    for(int i=0;i<=2;i++){
        string tmp=string(1,(char)(r+'0'));
        int nextrow=r+i-1;
        if(nextrow==-1){
            nextrow=m-1;
            flag_up=true;
        }
        if(nextrow==m){
            nextrow=0;
            flag_down=true;
        }
        dfs(deep+1,nextrow);
        if(dp[r][deep]>=gra[r][deep]+dp[nextrow][deep+1]){
            if(dp[r][deep]>gra[r][deep]+dp[nextrow][deep+1]){
                dp[r][deep]=gra[r][deep]+dp[nextrow][deep+1];
                route[r][deep]=tmp+route[nextrow][deep+1];
            }
            else{
                if(flag_up&&(nextrow==r||dp[nextrow][deep+1]<dp[r][deep+1])||flag_down)
                    route[r][deep]=tmp+route[nextrow][deep+1];
            }
        }
    }
}

void print_route(int i,int j)
{
    int len=route[i][j].length();
    for(int index=0;index<len;index++){
        printf("%d",route[i][j][index]-'0'+1);
        if(index!=len-1)printf(" ");
    }
    printf("\n");
}

int main()
{
    while(scanf("%d %d",&m,&n)==2){
        memset(dp,0x3f,sizeof(dp));
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++){
                scanf("%d",&gra[i][j]);
                if(j==n-1){
                    dp[i][j]=gra[i][j];
                    route[i][j]=string(1,(char)(i+'0'));
                }
            }
        long long ans=INF;
        for(int i=0;i<m;i++){
            dfs(0,i);
            ans=min(ans,dp[i][0]);
        }
        for(int i=0;i<m;i++)
            if(dp[i][0]==ans){
                print_route(i,0);
                printf("%lld\n",ans);
                break;
            }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值