Can you answer these queries? (区间更新, 开根号)

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 19869    Accepted Submission(s): 4697


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
最大数据是2^63,开63次根号就到头了,也就是说如果为1,则不需要操作;

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
#define MAX 100000

using namespace std;

struct node{
	int left, right;
	long long val;
}segtree[MAX<<2+5];
long long ship[MAX<<1];
void build(int root, int left, int right){
	segtree[root].left=left;
	segtree[root].right=right;
	if(left==right){
		segtree[root].val=ship[left];
		return;
	}
	int mid=(left+right)/2;
	build(root*2, left, mid);
	build(root*2+1, mid+1, right);
	segtree[root].val=segtree[root*2].val+segtree[root*2+1].val;
}
void destroy(int root, int ind){
	//cout << ind << ' ';
	if(segtree[root].left==segtree[root].right){
		segtree[root].val=ship[ind]=(long long)sqrt(ship[ind]);
		return;
	}
	int mid=(segtree[root].left+segtree[root].right)/2;
	if(ind<=mid) destroy(root*2, ind);
	else destroy(root*2+1, ind);
	segtree[root].val=segtree[root*2].val+segtree[root*2+1].val;
}
void attack(int root, int left, int right){
	//cout << root<< endl;
	if(left>segtree[root].right||right<segtree[root].left) return;
	if(left<=segtree[root].left&&right>=segtree[root].right){
		if(segtree[root].val==(segtree[root].right-segtree[root].left+1)) return;
		else{
			for(int i=segtree[root].left; i<=segtree[root].right; i++){
				if(ship[i]!=1){
				//	cout << i << ' ';
					destroy(root, i);
				}
			}
		//	printf("***\n");
			return;
		}
	}
	//int mid=(segtree[root].left+segtree[root].right)/2;
	attack(root*2, left, right);
	attack(root*2+1, left, right);
	segtree[root].val=segtree[root*2].val+segtree[root*2+1].val;
}
long long query(int root, int left, int right){
	if(left>segtree[root].right||right<segtree[root].left) return 0;
	if(left<=segtree[root].left&&right>=segtree[root].right) return segtree[root].val;
	return query(root*2, left, right)+query(root*2+1, left, right);
} 
void print(int root){
	if(segtree[root].left==segtree[root].right){
		cout << segtree[root].val << ' ';
		return;
	}
	print(root*2);
	print(root*2+1);
}
int main(){
	int N;
	int ca=0;
	while(scanf("%d", &N)!=EOF){
		ca++;
		printf("Case #%d:\n", ca);
		for(int i=1; i<=N; i++){
			scanf("%lld", &ship[i]);
		}
		build(1, 1, N);
		int M;
		scanf("%d", &M);
		int op, x, y;
		for(int i=1; i<=M; i++){
			scanf("%d%d%d", &op, &x, &y);
			if(x>y){
				x=x+y;
				y=x-y;
				x=x-y;
			}
			//cout << "*********\n";
			if(op){
				printf("%lld\n", query(1, x, y));
			}
			else attack(1, x, y);
			//print(1);
		//	printf("\n");
		}
		printf("\n");
	}
	return 0;
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值